Penjadwalan Ganti Otomatis 2 ISP di Mikrotik

Kali ini admin akan membahas mengenai penjadwalan 2 ISP secara otomatis di Mikrotik. Mekanisme ini bertujuan untuk memindah jalur internet pada jam tertentu. Misalnya kita ingin ISP 1 digunakan pada jam 6 Pagi hingga jam 1 malam. Kemudian kita menggunakan ISP 2 pada jam 1 hingga jam 5 Pagi.

Dalam contoh kasus seperti ini kita akan memanfaatkan System Script sebagai pemindah jalur dan System Schedule untuk menentukan kapan ISP cadangan akan dipakai.

  1. Pertama yang harus dilakukan adalah memasang LAN ISP-1 di ether1 dan ISP-2 di ether2
  2. Setting IP untuk ether1 dan ether2 sesuai dengan range IP modem. Di sini saya contohkan IP ether1 menggunakan IP 192.168.1.10 karena gateway modem di IP 192.168.1.1.
    /ip address
    add address=192.168.1.10/24 comment=ISP_1 interface=ether1 network=192.168.1.0
    add address=192.168.8.10/24 comment=ISP_2 interface=ether2 network=192.168.8.0
  3. Bikin routing ke masing-masing gateway sesuai IP modem. Jangan lupa menambahkan Comment pada Route ISP-1
    /ip route
    add comment=utama distance=1 gateway=192.168.1.1
    add distance=2 gateway=192.168.8.1
  4. Setting NAT untuk masing-masing gateway agar lokal network bisa mengakses internet.
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1
    add action=masquerade chain=srcnat out-interface=ether2
  5. Buat Script untuk memindah jalur menuju ISP-2 otomatis. Namai script dengan failover barangkali besok juga difungsikan sebagai switch failover.
    :if ([/ip route get [/ip route find comment=utama] disabled]=yes) do={/ip route enable [/ip route find comment=utama]} else={/ip route disable [/ip route find comment=utama]}
  6. Buat juga script back2main untuk mengembalikan jalur gateway internet ke ISP-1.
    :if ([/ip route get [/ip route find comment=utama] disabled]=yes) do={/ip route enable [/ip route find comment=utama]}
  7. Yang terakhir buat jadwal agar mikrotik bisa mengeksekusi script yang ada di langkah no.5 dan no.6. Sesuaikan kapan script failover dan back2main dieksekusi.

Keuntungan menggunakan script penjadwalan 2 ISP otomatis di atas adalah kita tidak perlu lagi memindah LAN dan setting ulang IP Gateway untuk mengubah jalur gateway. Semuanya sudah ditangani mikrotik sesuai dengan jadwal yang kita tentukan.

Copyright © 2022 - JasaPasang.net
Kontak CS Via Whatsapp
Online Support 24/7